[ tcl-Bugs-1282645 ] tcl8.0.4 configuration failed

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[ tcl-Bugs-1282645 ] tcl8.0.4 configuration failed

SourceForge.net
Bugs item #1282645, was opened at 2005-09-06 00:44
Message generated for change (Settings changed) made by dgp
You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=110894&aid=1282645&group_id=10894

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: 51. Configure and Build Tools
Group: obsolete: 8.0.4
Status: Open
>Resolution: Out of Date
Priority: 5
Submitted By: Nobody/Anonymous (nobody)
Assigned to: Mo DeJong (mdejong)
Summary: tcl8.0.4 configuration failed

Initial Comment:
i am trying to install ns2 version 2.1b5 on solaris.
when i run the install script i get the following error
associated with tcl.
checking for size_t... no
checking for uid_t in sys/types.h... no
checking for opendir... (cached) no
checking union wait... no
checking matherr support... no
checking return type of signal handlers... int
checking for vfork... no
checking for strncasecmp... no
checking for -lsocket... no
checking for -linet... no
checking for BSDgettimeofday... no
checking for gettimeofday... no
checking for gettimeofday declaration... missing
checking for -linet... no
checking for net/errno.h... yes
checking whether char is unsigned... configure: error:
can not run test program while cross compiling
tcl8.0.4 configuration failed! Exiting ...


----------------------------------------------------------------------

Comment By: miguel sofer (msofer)
Date: 2005-09-06 05:58

Message:
Logged In: YES
user_id=148712

I assume that "associated with tcl" means that what you are
showing is the complaint of Tcl's 'configure' script.

The (or just one?) problem seems to be that Tcl's
'configure' script thinks that you are cross-compiling,
which seems to be wrong (you would have mentioned that, right?).

You mention the 'install' script - I guess that is ns2's? It
does not seem to be doing the right thing for Tcl. At first
sight, this is a bug in the install script.

Maybe you could try first installing Tcl on its own, and
only then installing ns2 - maybe it will use the previously
installed Tcl?

----------------------------------------------------------------------

Comment By: Reinhard Max (rmax)
Date: 2005-09-06 04:35

Message:
Logged In: YES
user_id=124643

Do you have a special need for using those really outdated
versions of NS-2 and Tcl?
Current releases can be found here:
http://www.isi.edu/nsnam/ns/ns-build.html

----------------------------------------------------------------------

You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=110894&aid=1282645&group_id=10894


-------------------------------------------------------
SF.Net email is Sponsored by the Better Software Conference & EXPO
September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
_______________________________________________
Tcl-Bugs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/tcl-bugs